Skip to main content

KiCad basics

Download#

Download: https://www.kicad-pcb.org/download

Flowchart#

Creating project#

  • KiCad project window -> File -> New -> Project
  • KiCad project window -> File -> New -> Project From Template

Eeschematic#

  • KiCad project window -> <project>.sch
  • File -> Page Settings
    • Size: A3
  • Place -> Hierarchical Sheet
  • View -> Show Hierarchical Navigator
  • Symbol(๋ถ€ํ’ˆ) -> ์˜ค๋ฅธ์ชฝ ํด๋ฆญ -> Properties -> Edit Footprint
  • Tools -> Annotate Schematic
  • Inspect -> Electrical Rules Checker

Pcbnew#

1 oz == 0.035 mm, 1 mil == 0.0254 mm

  • KiCad project window -> <project>.kicad_pcb
  • Edge.Cuts์„ ์„ ํƒํ•˜๊ณ  ์•„์›ƒ๋ผ์ธ์„ ๊ทธ๋ฆผ
  • File - Board Setup
    • Design Rules
      • Net Classes
        • Clearance: ํŒจํ„ด๊ณผ ํŒจํ„ด ์‚ฌ์ด ๊ฐ„๊ฒฉ
        • Track Width: ํŒจํ„ด ํญ; ๋‘๊ป˜ 1 oz, ์˜จ๋„ 10 ๋„ ์ƒ์Šน์„ ๊ฐ€์ •ํ–ˆ์„ ๋•Œ, 1 mm์— 1 A (๊ณ„์‚ฐ๊ธฐ ๊ฐ’์€ ์™ธ๋ถ€ 0.3 mm ๋‚ด๋ถ€ 0.7 mm ์ •๋„๋ฉด ๋œ๋‹ค๊ณ  ๋‚˜์˜ด)
  • Tools -> Update PCB from schematic
  • PCB ์ˆ˜์ •
  • Inspcet -> Design Rules Checker
  • File -> Plot
    • Generate Drill Files
    • Plot

Reference#

Last updated on